[Tuto] Comment mettre en évidence uniquement la valeur maximale de chaque ligne dans un tableau Excel ?

[Tuto] Comment mettre en évidence uniquement la valeur maximale de chaque ligne dans un tableau Excel ?

Mais oui… Je suis sûr qu’il y a un truc dans Excel pour faire ça automatiquement. Voyons voir… Regardons dans la mise en forme conditionnelle, je crois que c’est là…

Mise en forme conditionnelle

Il y a plein de truc sympas, pleins de couleurs, mais pas de quoi mettre en avant uniquement la valeur maximale… C’est peut-être dans les autres règles ? Continuons notre exploration…

Nouvelle règle de mise en forme conditionnelle

Zut alors… Il va falloir trouver la solution tout seul…

Etape 1 : A nous de définir nos règles ! (d’abord !)

Sélectionnez votre tableau de valeurs pour créer une nouvelle règle de mise en forme comme suit :

Exemple - Nouvelle règle de mise en forme conditionnelle

Etape 2 : Ecrivons notre formule magique

=SI(B2=MAX($B2:$L2);VRAI;FAUX)

Règle mise en forme - Maximum par ligne

La formule mérite une petite traduction. En français, cela donnerait ceci :

Si ma cellule courante (B2 sans les $) est égale au maximum de ma ligne (MAX($B2:$L2) alors j’ai trouvé le vainqueur.

La subtilité réside dans l’utilisation ou non du fameux symbole $. Il faut lire ce symbole comme un cadenas. Il se place toujours avant l’information qu’il veut bloquer (la lettre de la colonne ou le n° de la ligne).

$B$2:$L$2 signifie “Bloque la colonne à B, bloque la ligne à 2” jusqu’à “bloque la colonne à L et bloque la ligne à 2” ou encore “Fais toujours référence aux cellules allant de B2 à L2”.

$B2:$L2 signifie “Fais toujours référence aux cellules allant de la colonne B à la colonne L, mais si les lignes changent, alors change les références en $B3:$L3, $B4:$L4, $B5:$L5 et ainsi de suite.

Les personnes qui ont cet article ont aussi lu :  [Tuto] Comment créer un graphique croisé dynamique ?

B$2:L$2 signifie “Fais toujours référence à la ligne 2, avec le même nombre de colonne qu’il y a entre B et L”. Si mon point départ change de colonne, alors les références deviennent C$2;M$2, D$2;N$2, E$2;O$2 et ainsi de suite”.

Comme nous voulons la valeur maximale par ligne, nous choisissons la deuxième option !

Etape 3 : Choisissez votre mise en forme en cas de succès

En cliquant sur le bouton “Format…”, vous devez sélectionner une mise en forme différente afin de mettre en évidence la cellule qui sera le maximum de la ligne. Ici, j’ai choisi de mettre le fond en rouge. Jugez du résultat :

Résultat - Mise en forme - Maximum par ligne

Faisons un test en mettant une valeur élevée dans la cellule B2 (ici 100) :

Résultat 2 - Mise en forme - Maximum par ligne

Parfait !

Etape 4 : Et si je souhaitais la valeur maximale par colonne ?

Je serais bien tenté de vous demander de faire l’exercice par vous-même… mais bon… voici la réponse :

=SI(B2=MAX(B$2:B$18);VRAI;FAUX)

Il suffit de changer les références dans le choix de la valeur maximale. Cette fois, c’est B$2:B$18, car je souhaite fixer le bloc selon les lignes et la rendre mobile selon les colonnes.

Cela donne immédiatement ceci :

Résultat - Mise en forme - Maximum par colonne

Etape 5 : Likez !

Si vous avez aimé cette astuce, faites-le moi savoir, likez la page, commentez la page !

Merci !

Partager l'article
  •  
  •  
  •  
  •  
  •  

Laisser un commentaire

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

Logo exceller avec la bureautique


​Vous êtes libre de recevoir gratuitement "​Les 15 fonctionnalités que seuls les VRAIS experts connaissent !​"